summaryrefslogtreecommitdiff
path: root/mcastseed/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'mcastseed/configure.ac')
-rw-r--r--mcastseed/configure.ac48
1 files changed, 48 insertions, 0 deletions
diff --git a/mcastseed/configure.ac b/mcastseed/configure.ac
new file mode 100644
index 0000000..ad1db27
--- /dev/null
+++ b/mcastseed/configure.ac
@@ -0,0 +1,48 @@
+dnl Process this file with autoconf to produce a configure script.
+
+AC_INIT(mcastseeder, 0.1)
+
+# Args deprecated http://www.gnu.org/software/automake/manual/automake.html#Modernize-AM_005fINIT_005fAUTOMAKE-invocation
+AM_INIT_AUTOMAKE #(AC_PACKAGE_NAME, AC_PACKAGE_VERSION)
+AM_CONFIG_HEADER(config.h)
+AM_MAINTAINER_MODE
+
+
+
+AC_CANONICAL_HOST
+case $host_os in
+ darwin*)
+ HOST_IS_DARWIN="yes"
+ ;;
+ *mingw32*)
+ HOST_IS_WINDOWS="yes"
+ ;;
+ *)
+ HOST_IS_DARWIN="no"
+ HOST_IS_WINDOWS="no"
+ ;;
+esac
+
+
+
+if test "$HOST_IS_WINDOWS" = "yes"; then
+ WSOCKLIB="-lws2_32"
+ AC_SUBST(WSOCKLIB)
+fi
+
+
+AM_CONDITIONAL(MINGW, [ test "$HOST_IS_WINDOWS" = "yes" ])
+AM_CONDITIONAL(DARWIN, [ test "$HOST_IS_DARWIN" = "yes" ])
+
+AC_ISC_POSIX
+AC_HEADER_STDC
+AC_PROG_CPP
+AC_PROG_CC
+AM_PROG_CC_STDC
+AM_PROG_CC_C_O
+
+
+AC_OUTPUT([
+Makefile
+src/Makefile
+])